Resolved
This incident has been resolved.
Monitoring
We implemented a fix and we are monitoring the results.
We will provide an update once the issue is fully resolved.
Investigating
We are currently investigating an issue with Market Data services.
Our team is fully engaged in resolving the issue as quickly as possible. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Copyright © 2025 Bullish Global. All rights reserved.
Bullish exchange is operated by Bullish (GI) Limited and regulated by the Gibraltar Financial Services Commission (DLT license: FSC1038FSA). Bullish (GI) Limited is a company incorporated and registered in Gibraltar (company: 119714) with its registered address at c/o Fiduciary Management Limited, Suite 23, Portland House, Glacis Road, Gibraltar GX11 1AA.