Bullish Exchange
Temporary System Interruption - Delays in portfolio balances, orders and trade history updates on the Bullish website as well as Fireblocks balances
Incident Report for Bullish
Resolved
The issue with the portfolio balances, orders and trade history on the Bullish website as well as Fireblocks balances has been resolved.
Posted May 08, 2024 - 09:52 UTC
Investigating
We are currently investigating a system issue affecting delays in portfolio balances, orders and trade history on the Bullish website as well as Fireblocks balances. Portfolio balances, orders and trade history updates via API are not affected.

Our team is fully engaged in resolving the issue as quickly as possible. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Posted May 08, 2024 - 06:38 UTC
This incident affected: Bullish website.