Bullish Exchange
Temporary System Interruption - Trading Halted for USDC/USD
Incident Report for Bullish
Resolved
Trading in USD/USDC is available as of 7:00 a.m. UTC Tuesday, Mar 26, 2024.
Posted Mar 26, 2024 - 07:01 UTC
Investigating
We will disable trading for USDC/USD. While trading will no longer be available for this market, we will enable trading for the new market USD/USDC at 7:00 a.m. UTC Tuesday, Mar 26, 2024.

Deposits and withdrawals as well as trading for all other markets remain unaffected.

We will provide updates as they become available.
Posted Mar 26, 2024 - 06:45 UTC
This incident affected: Trading (Spot Trading).