Bullish Exchange

Degraded Performance - Delayed processing of Deposit and Withdrawal transactions of BCH & LTC

Incident Report for Bullish

Resolved

This issue has been resolved
Posted Apr 23, 2025 - 21:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2025 - 18:36 UTC

Investigating

We are currently investigating an issue that is causing a delay in the processing of deposits and withdrawals of BCH & LTC

Our team is fully engaged in resolving the issue as quickly as possible. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Posted Apr 23, 2025 - 15:12 UTC
This incident affected: Deposits and Withdrawals (Bitcoin Cash (BCH), Litecoin (LTC)).