Bullish Exchange

Temporary system issue in Bullish exchange email service

Incident Report for Bullish

Resolved

The Bullish exchange email service is fully operational. All correspondence should have returned to normal Thank you for your patience.
Posted Sep 21, 2023 - 15:39 UTC

Investigating

We are experiencing an issue with the Bullish exchange email service which is causing customers to receive outdated deposits and withdrawals emails. Our team is fully engaged in resolving the issue as quickly as possible. We confirmed that deposits and withdrawals services are not impacted. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Posted Sep 21, 2023 - 05:14 UTC
This incident affected: Bullish email service.