Bullish Exchange
Degraded Performance - CUBIX withdrawals
Incident Report for Bullish
Resolved
Issue is resolved
CUBIX deposits and withdrawals are currently available.
Posted Jan 10, 2025 - 16:02 UTC
Identified
We have identified an issue with CUBIX deposits and withdrawals for USD.
As a result CUBIX deposits and withdrawals are currently halted and will be unavailable.
Posted Jan 10, 2025 - 13:28 UTC
Investigating
We are currently investigating reports of degraded performance in CUBIX withdrawals.

Our team is fully engaged in resolving the issue as quickly as possible. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Posted Jan 10, 2025 - 11:21 UTC
This incident affected: Bullish website and Deposits and Withdrawals (Fiat (USD)).