Bullish Exchange
Temporary System Interruption - Bullish Email Notifications
Incident Report for Bullish
Resolved
The issue with the Bullish email service has been resolved.
Posted Oct 03, 2024 - 09:41 UTC
Investigating
We are currently investigating a system issue affecting our email notification service.

Our team is fully engaged in resolving the issue as quickly as possible. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Posted Oct 03, 2024 - 06:55 UTC
This incident affected: Bullish email service.