Bullish Exchange
Temporary System Interruption - Bullish Website
Incident Report for Bullish
Resolved
The issue with the Bullish exchange website's position tab and portfolio positions been resolved.
Posted Nov 20, 2024 - 05:56 UTC
Investigating
We are currently investigating a system issue affecting the Bullish exchange website's position tab and portfolio positions.

Our team is fully engaged in resolving the issue as quickly as possible. We apologize for any inconvenience caused and will provide updates as soon as they become available.
Posted Nov 19, 2024 - 16:36 UTC
This incident affected: Bullish website.